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Introduction to SharePoint 

X SharePoint is NOT: 

 A file management system 

 A “cloud” file server 

 An application 

 A share drive replacement 

 SharePoint is: 

 A Web-Based Platform 

 A Collaboration Tool 

 A Virtual Workspace for Projects 

 A Process Automation Tool 

Site  The main collection of sub-sites, pages, lists, and libraries that encompasses all content re-

lated to a location (i.e. passport centers, agencies, or headquarters). This site is found on a 

SharePoint Site Collection. 

All of CPC’s content is found on the CPC site on the PPTSRD site collection (PPTSRD / CPC) 

Sub-Sites The top-level site (PPTSRD/CPC) can be further divided into sub-sites for individual offices. 

These sub-sites can in turn be further divided into team sites, project sites, etc. Each sub-

site can have unique pages, libraries, and lists. 

Pages Editable spaces that can display information (such as contact information) or aggregate con-

tent from around a site. A page can include simple text, hyperlinks, or web-parts that link to 

other elements of the page’s parent site. 

SharePoint Infrastructure  

Elements of a SharePoint Site  
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Site 

PPTSRD / CPC 

Sub-Site 

PPTSRD / CPC / {Office 2} 

Sub-Site 

PPTSRD / CPC / {Office 3} 

Sub-Site 

PPTSRD / CPC / {Office 2} / {Team 2} 

Sub-Site 

PPTSRD / CPC / {Office 1} 

Page 1 

List 1 

Library 1 

Library 2 

Page 1 

Page 2 

Page 3 

Sub-Site 

PPTSRD / CPC / {Office 2} / {Team 1} 

List 1 

List 2 

Library 1 

Sub-Site (Project Team) 

PPTSRD / CPC / {Office 2} / {Team 2} / 

{Project 1} 

List 1 

Library 1 

Lists Collections of similar content items that are connected to user defined columns. SharePoint 

lists are similar to Excel spreadsheets, but have the added benefit of “views”.  

Views allow users to interpret information in many different ways. For example, a list of 

deadlines can be viewed as a calendar, or different team members can view different col-

umns depending on their need to know. 

Libraries Libraries are specialized lists that allow for the storage and distribution of documents such as 

Microsoft office documents, PDFs, images, or multi-media files. Libraries enable document-

specific editing features and allow users to view the revision history of individual documents. 

Sample Site Infrastructure  
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SharePoint sites and sub-sites act as landing pages for a location, office, team, or project. Every site 

can be customized to include pertinent & unique information. This information is displayed using Web 

Parts, which are modular units of information that form the basic building block of a SharePoint sites. 

Web Parts can be used to dynamically show the content of lists & libraries or to display rich text & 

graphics on SharePoint sites. Below are common web parts used by CA SharePoint Sites: 

❶  Documents Portal: Displays the content of a library or list from within the site. The data or 

documents can be filtered using views if necessary. 

❷  Content Editor: A rich text editable space that can be used to display print information such 

as announcements, contact information, helpful links etc. 

❸  Calendars: Displays a list in calendar view to highlight important dates, such as holidays. 

❹  Graphics: Images or logos can be added throughout the site using web parts.  

❶ 

❷ 

❸ 

❹ 

Sites, Sub-Sites, & Pages   

❶ 

❷ 

SharePoint Site 

SharePoint Page 
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A SharePoint list is similar to an Excel spreadsheet, but unlike a spreadsheet, SharePoint provides sev-

eral predefined lists as well as the ability to build custom lists. Below are common predefined list in 

SharePoint: 

The standard list has two primary elements: 

 Columns: SharePoint lists are very similar to Excel spreadsheets in having columns and data. 

Creating a “new item” brings up a dialog that allows users to input column information easily. 

 Views: Users can select multiple views to view lists differently; views can also be set by indi-

viduals. Views can also be used to filtered how data is exported to Excel. 

List Type When to Use Benefits 

Announcements To display announcements on a site. 
Expiration dates can be entered for  

announcements. 

Links To track hyperlinks. 
Uses a Hyperlink column that automatically 

formats entered text as HTML anchor links. 

Calendar To track calendar items. Can synchronize with Outlook. 

Tasks To track tasks. 
Can synchronize with Outlook; tasks lists 

can be grouped with summary tasks. 

Project Tasks To track work items for a project. Can display as a Gantt chart. 

Issue Tracking To track trouble tickets. 
Works well with issues that have three 

states — open, closed, and resolved. 

Lists   

❷ 

❶ ❶ 

SharePoint List 
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Libraries   

A SharePoint library is a specialized list that houses documents, photographs, & other media. Items in a 

library can be augmented with meta-data in columns (just as in lists). In addition to columns for meta-

data, a SharePoint Library allows users to track the history of document revisions through versioning. 

 

The standard list has two primary elements: 

 Columns: Documents in a SharePoint library following best practices should be organized with 

meta-data in columns. 

 Views: Users can select multiple views to view lists differently; views can also be set by indi-

viduals. This allows groups or individuals to sort a single list of documents to show only the docu-

ments they need. 

❸  Versioning: Users check out and check in documents to make edits. These edits are tracked in 

the form of versions that can be viewed for a single document. Typically a library will limited ver-

sions to 10 per document.  

❶ ❶ 

❷ 

❸ 
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Navigating to the various elements of a SharePoint site can be done through five primary methods: 

❶ Navigation Bar: Allows for navigation throughout various sub-sites and sites. Links on the 

navigation bar are manually selected to provide users useful links from anywhere within the site. 

❷ Navigation Menu: Provides quick access to the current site’s document libraries, lists and pages. Only 

the content within the current site or sub-site is visible in this menu.  

❸ Header Address: The complete path for the site a user is currently on is shown in the header pane. Users 

can click on sub-sites that are higher in the hierarchy  to retrace their steps.  

❹ Navigate Up: Users can click on the icon at any point to navigate back to the parent site 

collection from whether they are currently located in the site. 

❺ Web-Parts: Web-parts within the page provide users direct access to information in certain 

lists, libraries, or calendars. Users can interact with these items directly through the web-part.  

❶ 

❷ 

❸ 

❹ 

SharePoint Navigation 

❺ 
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SharePoint Search 

Searching within a SharePoint site is very simple. In the top-right hand corner of every site or page, 

there is a search field ❶ Search this site: 

Keep in mind: 

 The search scope for a field is of the current site and any sites or pages that are lower in the 

hierarchy.  

 Search results are security trimmed, meaning only content that a user has permissions to will 

appear in the results. 

 SharePoint can search for keywords within documents (except non-searchable PDFs). 

 

1) Enter a keyword into the search field, then hit enter or click the magnifier: 

2) SharePoint will return every instance of <Report_5> in the current site and all sub-sites: 

❶ 

The following was returned: 

❷ A document with the exact title. 

❸ A site with a document listed. 

❹ A view within the library where 

this document is found that shows the 

document. 

Clicking on a link will direct you to 

that item. 

❷ 

❸ 

❹ 
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Creating Individual Views for Lists and Libraries 

A helpful step to take when accessing a library or list for the first time is creating personal views (which 

are only accessible to you). Personal views give you the ability to view only documents pertinent to you. 

1) To begin, navigate to ❶ Library / List Tools > Library / List > Create View: 

 

 

 

 

 

2) In the window that appears, select the view that is most relevant to your needs, the most common is 

❷Standard View: 

 

3) Complete the following sections of the next screen: 

❶ 

❷ 

Name: Differentiate this view with a 

unique name that will help you remember 

what the view filters for (especially if you 

create multiple views for yourself). 

Columns: Select which columns from the 

list or library will be visible in your per-

sonal view. You can also adjust the order 

that the columns are shown. 

NOTE: This is very helpful for views for 

Excel export (if you only want certain col-

umns exported). 
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Sort: In this field, determine how items 

will be sorted by selecting a column 

(even those that will be hidden) and 

decide whether the information will be 

shown in ascending or descending or-

der. You may select multiple columns to 

sort. 

Filter: This is where you can filter results 

to show only the information you need. 

Select the second option and then filter 

by column. Items / rows are filtered to 

only show rows/items that have an entry 

in the column selected that matches ei-

ther: 

A) A specific word (such as Office 2) 

B) Your name or a date.  

 Type [Me] for the created by / modi-

fied columns to only display items 

that you created or modified 

(depending on the column selected) 

 Type [Date] to only display rows/

items in a “date” column that match 

today’s date.  

❸ 

If necessary, you may add additional columns to filter by selecting ❸Show More Columns. 

 

4)  After inputting all necessary information, click OK to save your new personal view. 

Continues on the next page 
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5) You may not view this list or library with your own 

❹personal view or those designated by your site develop-

ers.  

NOTE: You can have multiple personal views that help you 

view the information in the list or library in different ways.  

 

One of the most important ways views can help you is cre-

ating pre-defined lists ready to be downloaded to Excel. 

❹ 

Working with Lists 

SharePoint makes it easy for you to download information Excel for offline analysis. SharePoint views can 

be used to prepare data in a certain way to save time whenever you download similar data to Excel. Be-

low is the procedure to download information from SharePoint to Excel: 

1) From a SharePoint List, make sure you have a view 

prepared (if necessary). In this example, we have a 

personal view called ‘Office 2 Supervisor Report’ in 

the ‘Item Tracking’ List. This view filters by office for 

“office 2” and sorts items by date. 

2) First, ensure the view is selected by navigating to 

❶List Tools > List > Current View: 

3) Below is how the view effects the information displayed in the list: 

❶ 

Regular List View: Office 2 Supervisor Report 

Continues on the next page 

Downloading List Data to Excel  

Lists are critical elements of a SharePoint Site. This section will highlight the different ways you can inter-

act with a SharePoint List. 
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4) With the proper view selected, navigate to ❷List Tools > List > Export to Excel: 

5) In the pop-up window that appears, click ❸Save to save a 

copy on your desktop, click ❹Open to open the file directly 

into Excel and save later. 

6) The information is now available in Excel format (only the 

columns in the view selected are downloaded to Excel): 

❷ 

 

❹ 

❸ 

NOTE: The columns [Item Type] and 

[Path] are automatically downloaded 

with any SharePoint list and can be de-

leted. 

Adding Items to a List  

Adding an item to a list is an important function of any SharePoint site. You can input data to a list di-

rectly, by opening the list itself or through any web-part views that show the list’s information: 

OR 
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1) Either way, once you click on                the following window displays: 

2) Complete all of the fields 

(especially the required fields, noted 

by the red asterisk). These fields 

correspond to the columns in the 

list. 

3) Once all of the fields are com-

plete, click ❶Save. The item is now 

part of the list: 
❶ 

New Item Window List with New Item 

A 

A 

B 

B 
C 

C 

Working with Libraries 

Document Libraries allow you to work collaboratively on documents. This section will highlight the differ-

ent ways you can work with SharePoint Library. 

Uploading a Document  

You can add a document by opening a library directly or through any web-part views that show a li-

brary’s content: 

OR 
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1) Either way, once you click on                the following window displays: 

2) Click on ❶ Browse and navigate 

through your computer / shared drive 

to find the document: ❶ 

3) Once the document is found, click  ̧OK. 

4) The following window opens: 

 ̧

Complete all of the fields 

(especially the ones that are 

marked with a red asterisk). 

These fields correspond to the 

columns in the library that act as 

meta-data tags, enabling easy 

filtering and sorting. 

After completing all of the fields, 

click on ❷ Check In to submit 

the document to the library. 
❷ 

New Document Window List with New Item 

A 

B 

C 

A B 

 

C 

The document is now listed in the Document Library with all necessary tags. 
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Editing a Document  

SharePoint allows multiple users to contribute to the same document(s) and track the changes made. 

The following example will look at editing a Word document in the “Reports” Library: 

1) Open the “Reports” Library and select the document that needs to be edited, then click                  

❶ Edit Document: 

2) In the pop-window that appears, click ¸OK: 

3) The document now opens in the Microsoft application it 

opens in (Word = docx, Excel = xlsx, etc). 

4) Make sure to ❷ Enable Content: 

5) Complete all the necessary edits or changes to the document. 

6) When the document is ready, click on the ❸  icon at the top left-hand corner of the document: 

7) Next close out of the window by clicking on the ❹ button. The following window will appear: 

❶ 

 ̧

❷ 

❸ 

❹ 

8) Click on ❺ YES. 

❺ 
Continues on the next page 
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9) In the window that appears, enter any notes about the 

edits made in this version. Once the comments are en-

tered, click ¸OK: 

10) The document is now “checked-in” to SharePoint. 

 ̧

Checked-In: Documents that are “checked-in” are open to any user for editing. 

Checked-Out: Document that are “checked-out” are available to only the user that checked the 

document out. While checked-out, all other users are locked out of editing the document. 

It is very important to remember to check in documents when you no longer need to edit them. 

Document Versioning  

To check a documents versioning history and view previous iterations of a document, follow these steps: 

1) Select the document from the 

Library, then click ❶Version  

History: 

 

 

2) A pop-up with the versioning his-

tory for this document displays: 

❶ 

 Every iteration of the document will be 

displayed in this list, including who modi-

fying the document and when. 

 Clicking on the arrow next to the modified 

date of a version allows you to...  

 view the version. 

 restore that version 

to the library. 

 delete the version. 
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Creating Alerts  

SharePoint Alerts can be set up to notify you when changes are made to certain documents or entire 

libraries / lists. Below is the procedure to create these alerts. 

To set up an alert for… 

A single document:  

Select the document then navigate to ❶ Documents > Alert Me > Set alert on this document: 

❶ 

 Complete the form that appears, then 

click ¸OK 

 Depending on the options selected, you 

will receive emails like the one below 

whenever changes are made to this doc-

ument: 

A list/library:  

Navigate to ❷ Library > Alert Me > Set alert on this library / list: 

 ̧

 ̧
❷ 
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You can connect your Outlook Calendar to a SharePoint calendar to always see the most up-to-date in-

formation from a SharePoint calendar displayed in your Outlook calendar. Below is the procedure to do 

this: 

1) Navigate to a SharePoint calendar 

by selecting the name form the 

side bar, or clicking on the title of 

a Web-Part. 

2) Either way, you will be brought to 

the calendar page. 

3) From here, navigate to ❶Calendar 

Tools > Calendar > Connect to 

Outlook 

 

4) In the window that appears, click on ❷ Allow. 

5) In the next window, select Allow as well. 

6) In the third window, click on ❸ Yes. 

 

 

 

 

 

 

The SharePoint calendar is now connected to Outlook. 

❶ 

❷ 

❸ 

Connecting SharePoint Calendars to Outlook 
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Create a New List  

1.0) From a site, navigate to ❶ Site Actions > More Options 

Site Designers have the ability to create and modify the structure and content of SharePoint sites. This 

guide will provide a detailed walkthrough of how to create and maintain standard elements of a Share-

Point site.  

Click on a section in the SharePoint site below to jump to that section of the handout, or continue direct-

ly to view the walkthrough of every section: 

Lists 

Libraries 

Pages 
Web Parts 

Navigation 

Page Settings 

❶ 

SharePoint  Lists 

Lists are the backbone of a SharePoint site. It is good practice to develop a site’s list (and library) struc-

ture before developing pages and layouts. The following is a step-by-step guide on how to create and 

maintain a SharePoint list: 
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1.1) In the window that opens, select ❷ List from the side menu: 

1.2) A list of list options is shown, select the option that meets the needs of the list you are creating.                              

        The most common list types in CA SharePoint sites are highlighted below:  

1.3) This guide will walk through the creation of a ❷Calendar List and a ❸Custom List.                              

❷ 

❷ ❶ ❸ 

❹ ❺ 

❻ 

❶ Announcements: A pre-defined list that al-

lows for easy entry of announcements that can 

be displayed throughout the site. Expiration 

dates can also be added to take announce-

ments down after a certain date. 

❷ Calendar: A pre-defined list that allows for 

easy entry of dates and events. Enter calendar 

events in a list format, then view the infor-

mation in a calendar format. Information en-

tered into this list can also be synchronized 

with Outlook. 

❸ Custom List: A blank template that allows a 

user to define the columns as needed. 

❹ Links: A pre-defined list that provides an easy template to track hyperlinks. Contains a hyper-

link column that auto formats HTML anchor links that are entered as text. 

❺ Project Tasks: A pre-defined list that allows for easy tracking of project tasks and work items. 

This tool is especially helpful since it can display task information as a Gantt chart. 

❻ Tasks: A pre-defined list that allows for easy tracking of tasks. These tasks can be synchro-

nized with Outlook tasks as well. 
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Calendar List  

1.4) Select ❶Calendar from the list selection menu.  

1.5) Enter a name for the calendar into the ❷Name field.  

1.6) Click on ❸Create after inputting a title. 

                            

1.7) The new calendar list will appear in the default View for a Calendar List (Calendar):  

1.8) To facilitate easy event entry, navigate to ❹Calendar Tools > Calendar. Once in the Calendar rib-

bon, click on the ❺View dropdown and select ❻All Events: 

 

 

 

 

❶ 

❷ 

❸ 

❻ 

❺ ❹ 
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1.9) The list will now display in the Standard View: 

 

 

1.10) Click on ❼                         at the bottom of the list to create a new event. After clicking, this pop

-up window appears: 

 

 

 

 

    

 

 

 

 

 

 

 

 ❽ Attach File gives you the option to attach a file from your desktop such as a meeting agen-

da, relevant materials, etc. 

 (G) Category allows you to categorize an event according to standard event types, or by creat-

ing a unique category: 

 

 

 

 (H) All Day Event removes the option to choose start and end times. 

 (I) Workspace prompts you to create a meeting workspace.  

1.11) After making your selections, click  ̧Save.  

To learn how to create a workspace, continue. If not click here (page 30) to move to Custom Lists. 

❼ 

The following fields are required: 

(A) Title: type in the field 

(B) Start Time: type or select from calendar pop-up 

(C) End Time: type or select from calendar pop-up 

Other important fields that are not required: 

(D) Location: type in the field 

(E) Description: type in the field 

(F) Recurrence: If selected, these additional fields 

are required: 

Additional selections: 

❽ 

· 
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If you elected to create a workspace in the calendar creation menu, the following screen appears:  

 

 

 

 

 

 

 Type in the Title and URL Address for this new site. 

 Use the same permission as the parent site. 

 Click ¸OK. A template selection screen appears: 

 

 

 

 

 

 

1.12) Select the Meeting Template you wish to use; Basic Meeting Workspace is a very good option.  

1.13) Clicking ¸OK will load the new meeting workspace: 

 

 

 

 

 

 

Meeting Workspaces  

· 
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1.14) The Basic Meeting Workspace has four sections: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

❶ 

❶ Objectives: To add objectives to this list, 

click on Add new item.  

In the window that appears, enter an objective, 

then click Save: 

❷ 

❷ Agenda: To add a new item to the agenda, 

click on Add new item.  

In the window that appears, complete the re-

quired fields, then click Save: 

❸ Attendees: To add meeting attendees, click 

on Manage attendees.  

In the window that appears, navigate to List 

Tools > Items > New Item: 

 Complete the required fields, then click Save. 

*Note: the Name field is connected to the GAL, so the 

named entered must match a name in the GAL. 

❸ 
❹ 
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1.17) Double click on the green event box to bring up the event details window: 

 

 

❹ Document Library: To add documents to 

the meeting space, click on Add document.  

In the window that appears, browse for the 

document to upload, then click OK: 

 This screen displays all of the infor-

mation for the event.  

 Users can click on the ❶Workspace 

link to go to the meeting workspace for 

the event.  

 If changes are needed, click on the 

❷Edit Item button (only available to 

Site designers). 

❶ 

❷ 

1.15) To return to the Calendar List View, click on Go to  

Calendar under the event information in the upper left-hand cor-

ner of the workspace: 

1.16) The event that was created is now viewable in the 

calendar view: 
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1.22) Returning to the project workspace, you will notice a new ❹sidebar with every date in the series: 

 

1.18) In this example, we will click on the Edit Item 

button to make a change to the event: 

1.19) Check the box next to the ❸Recurrence option. 

 This will bring up options specific to recurrence: 

 In this example, we will make the event occur 

weekly, for 10 iterations: 

1.20) If you return to the main calendar, you will see the event repeat on  

every Tuesday: 

 

1.21) Click on any of the events in the series, then click on the Workspace link 

in the details window: 

❹ 

 Clicking on each date in the se-

ries will display a new work ar-

ea. 

 Each iteration of the series has 

unique Objectives, Agendas, 

Attendees, & Documents! 

 Best Practice: Use the recur-

rence feature for ongoing meet-

ings to track agendas and docu-

ments for previous meetings. 

❸ 
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Custom List  

1.23) Select ❶Custom List from the list selection menu.  

1.24) Enter a name for the calendar into the ❷Name field.  

1.25) Click on ❸Create after inputting a title. 

1.26) The new list will appear in the default View for a List (All Items):  

 

 

 

 

❶ 

❷ 

❸ 

❹ 

1.27) The first step in list construction is to create columns. 

1.28) Click on ❹Create Column. A column creation window 

appears, complete the form as follows: 

 Type a name for the column in the ❺Title field. 

 Select the type of data the column will contain 

from the ❻list of options. 

 Depending on the type of list selected, different 

options will be available in the ❼Additional Col-

umn Settings section. 

 Select options that make sense for the type of in-

formation that will be in the column. 

 Once complete, click OK. 

❺ 

❻ 

❼ 

 
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1.29) In the Item Tracking list example, we will create two columns in addition to “title”: 

1.30) Returning to the list, you will notice that the list will have three columns:  

1.31) To add data to the list, click on the                         button at the bottom of the list. 

 

 

Column #1: Date 

Note the Date specific options that be-

come available in the Additional Col-

umn Settings section 

Column #2: Office 

Continues on the next page 

Note the Choice specific options that 

become available in the Additional 

Column Settings section 
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1.32) After clicking the add new data but-

ton the following pop-up window appears: 

 Every column you created is 

listed in this form.  

 Those that require data are 

marked with a red asterisk. 

 After inputting/selecting data for 

each field, click on Save. 

 The data is now in the list:   

1.33) If you need to edit an item in a list, follow these steps: 

1. Check the box of the row that needs editing. 

2. Then, click on Edit Item 

3. The pop-up window for the item appears, make 

the required edits and click Save. 

 

Views  

1.34) After creating columns and adding items, Site designers should create views for the list.  

 Public views are similar to Personal Views that were discussed in Module 1, but can be ac-

cessed by groups of users. 

1.35) In this example, we will create a view for Office 3 so they only see the items assigned to their of-

fice. There are many different ways you can use views, but the process of creating them is the same. 

❶ 1.36) To begin, navigate to        

❶ List Tools > List > Create View 

on the ribbon: 
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1.37) There are several options available on the next window; for this example, we will choose the 

❷Standard View: 

 

 

 

1.38) Next, the Create View screen is shown, customize the view by completing the following sections: 

 

❷ 

Name: Assign a name to this view (typically the group the view is 

for, or what it filters for, in this case “Office3”: 

Audience: Select “Create a Public View” when creating a 

view as a Site designer: 

Columns: Select which columns will be visible in this 

view. In this example, the Office column does not need 

to display since all entries will come from the same 

office, Office 3: 

NOTE: You can also change the order that columns are displayed by rearranging the numbers on the 

right-hand side. 

Sort: You have the option to sort rows by up to two col-

umns. In this example we will sort by date in descend-

ing order so newer items are displayed before older 

items: 

Filter: This is where you filter the results to include only 

Office 3 by selecting Office from the column selection 

drop-down and then typing in the value “Office 3”: 
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1.39) After inputting all of the information, click OK to build the view. 

 

 

1.40) The new view now only displays Items that were 

assigned to Office 3; the items are shown in descend-

ing order; and the Office column is no longer visible 

(but still present in the background): 

1.41) To change a view, navigate to ❸ List > 

Current View and select a different view from 

the drop-down menu: 

❸ 

1.42) Every view for the list will be shown in 

this drop-down menu (including your own 

personal views) 

1.43) Every view has a unique URL that will bring users directly to the view. Copy the URL from the URL 

bar when you have the view selected for the list. You should see the view’s title at the end of the ad-

dress: http://ca.m.state.sbu/sites/PPTSRD/SPTrain/prototype/Lists/Item%20Tracking/Office%203.aspx 

NOTE: Any spaces in the title of a list or view will be display in the URL as “%20” (highlighted in blue) 

Use the URL link in team sites or other pages where you want members of a specific team to see this 

list through their unique view. 

Delete a List  

In order to delete a list, follow these steps… 

1.44) While in a list, navigate to ❶List Tools > List > List Settings 

1.45) Under Permissions and Man-

agement, select ❷Delete this List: 

1.46) In the pop-up that appears, 

select ·OK 

❷ 

❶ 

 
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Create a New Library       

2.0) From a site, navigate to ❶ Site Actions > More Options 

 

 

SharePoint  Libraries 

Libraries are specialized lists that enable easy sharing of documents in a SharePoint site. The following 

is a step-by-step guide on how to create and maintain a SharePoint library: 

❶ 

❷ 

2.1) In the window that opens, 

select ❷ Library from the side 

menu: 

2.2) A list of library options is shown, the most com-

mon and best option for the majority of libraries is 

the ❸Document Library option: 

❸ 
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2.3) Select ❸Document Library from the library selection menu.  

2.4) Enter a name for the library into the ❹Name field.  

2.5) Click on ❺Create after inputting a title. 

2.6) The new library will appear in the default Standard View for a Library List:  

❺ 

❹ 

❸ 

Modifying a Library       

2.7) Libraries are specialized lists, so the same procedure for creating list columns apply to libraries. You 

can review these steps by clicking here (pg.30). Consider the following best practice when creating col-

umns for your document libraries: 

It is highly suggested that users do not create folder based document libraries. Instead, create columns 

that correspond to sub-folders and create “folder-like” views that filter data into various categories.  

Below is an example: 

Folder Structure Flat View Structure (Best Practice) 

  

This structure quickly becomes 

difficult to manage in SharePoint. 

It also limits the search function-

ality. 

Assigning columns to a document allows all documents to be 

housed on the same list, but at the same time allows for filtering by 

view. 

For example, the view “Office 2 - Project 2” would only show docu-

ments that were assigned “Office 2” and “Project 2”, acting as a 

virtual folder selection. 
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Adding Documents       

2.8) Once the library is built, you can begin the initial importation of documents. There are two primary 

methods for uploading these initial documents. 
 

Method 1: Uploading Documents through SharePoint 

2.9) Begin by clicking on the                        button at the bottom of the library list: 

 

 

 

 

2.10) The Upload Document window appears, click on ❻browse to search for the document on your 

computer, then click OK: 

2.11) Next, enter the metadata for the document (these fields are connected to the columns you creat-

ed). If a column was marked as required, a red asterisk will appear next to that entry. Complete the 

fields as required and click ❼Check In: 

❻ 

 

❼ 

The document is now in the docu-

ment library: 

Continues on the next page 
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Method 2: Uploading Documents through Windows Explorer 

This method is very helpful if you need to transfer a lot of documents at once: 

 

2.12) Navigate to ❽ Library Tools > Library > Open with Explorer: 

 

 

 

 

2.13) This opens the SharePoint Library as a folder in Windows: 

 

 

 

 

 

 

2.14) Drag all of the necessary documents from share drives or desktop folders into this folder. 

 

 

 

2.16) The library is now viewed as a datasheet (notice the document that was dragged into the folder): 

 

❽ 

2.15) Return to SharePoint, then navi-

gate to ❾ Library Tools > Library > 

Datasheet View: 

2.17) Complete the metadata for each document, making sure 

to fill in every column. 

 

 

❾ 
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2.18) Finally, navigate to ❿Standard View > Library Tools > Documents: 

 

 

 

 

 

2.19) All of the documents that were dragged into the windows explorer folder have a green arrow 

over the icon, this indicates that they are “checked-out”. Refer to Module 1’s section on Checking Out 

Documents for an explanation of what checking documents entails.  

Select each document with an icon: 

 

 

 

 

 

 

 

2.20) Once all of the documents are 

selected, click on ⓫Check In. 

2.21) In the pop-up window, select 

“NO” for retaining your check out: 

2.22) All of the documents are now 

checked in and tagged. 

⓫ 

Continues on the next page 

❿ 
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Document Versioning       

Site designers can enable versioning for an entire document library. Versioning is very helpful for track-

ing changes to a document without saving multiple “versions”. Below are the steps to enabling version-

ing: 

2.23) Navigate to ❶ Library Tools > Library > Library Settings: 

 

 

 

2.24) Under General Settings, click on Versioning Settings: 

2.25) In the versioning settings screen, select options that work for your needs.  

In general, it is good practice to select ❷Create major versions in the Document Version History section 

and ❸Yes in the Require Check Out section: 

 

 

 

 

 

 

 

 

 

 

TIP: Keep the limit of versions to 10. After making your selections, click on OK. 

 

❶ 

❷ 

❸ 

 
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2.26) With versioning on and check out required, only one user will be able to edit a document at a 

time. The most recent version of a document will also display in the document library. 

 

 

 

2.27) To check the version his-

tory for a document (if version-

ing is enabled), navigate to 

❹ Library Tools > Documents > 

Version History: 

 

The following window appears: 

 Every iteration of the document will be dis-

played in this list, including who modifying 

the document and when. 

 Clicking on the arrow next to the modified 

date of a version allows you to...  

 view the version. 

 restore that version 

to the library. 

 delete the version. 

Delete a Library  

In order to delete a list, follow these steps… 

2.28) While in a library, navigate to ❶Library Tools > Library > Library Settings 

2.29) Under Permissions and Manage-

ment, select ❷Delete this document 

library 

2.30) In the pop-up that appears, se-

lect ·OK 

❷ 

❶ 

 



CA/PPT/S/TO                                                                       

42                          Module 2: SharePoint Site Development 
Table of 

Contents 

SharePoint Infrastructure       

3.0) Before a SharePoint page can be built, we need to ensure that we have the proper infrastructure. It 

is best practice to include a Site Assets Library in all SharePoint sites. This is a library where SharePoint 

Pages, images, and other media can be stored. 

 

3.1) Begin by creating a Site Asset Library. To do this, navigate to ❶ Site Actions > More Options 

 

 

 

 

 

 

 

 

 

 

3.3) In the window that opens, select ❷ Library from the side menu, then ❸Documents Library:  

 

SharePoint  Pages & Web Parts 

Pages are spaces where information can be aggregated and displayed. Below is a step-by-step guide on 

creating a Page: 

❶ 

❷ 

❸ 

In the ❹Name Field, 

enter the name for 

this document li-

brary. The name for 

this library is: 

Site Assets 

 

Then click ❺Create 

❹ 

❺ 
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3.4) A Site Assets Library for your SharePoint site is now available. This document library will store any 

pages that you create for the site and house images and other media used throughout the site.  

 

3.5) With the new document library opened, create a new column with the following criteria: 

Name: Media Type 

Type: [Choice], with the following options: [Page] & [Image] (add other media as needed) 

^ TIP: Assign “Page” as the default choice. 

Additional Options: select [YES] for requiring information and [No] for Fill-In 

NOTE: You can review how to create a column by clicking here (pg. 30). 

 

3.6) Next, create two views;  

View 1 (Pages): Standard View > Filtered for the [Page] option in the [Media Type] column  

View 2 (Image): Standard View > Filtered for the [Image] option in the [Media Type] column  

NOTE: You can review how to create a view by clicking here (pg. 32). 

 

3.7) The SharePoint site’s Site Assets Library is now ready to house all the media for your SharePoint 

Site. Any media that you use for the site should be housed in this library. Create as many media type 

choices and views as there are media types in your site: images, videos, etc 

Creating Pages       

In addition to the main site page that is automatically created, site designers can create additional web-

part pages that can be used to aggregate and display information for end-users.  

After a brief walkthrough of how to create a page, we will explore the use of web-parts in both these ad-

ditional pages and the main SharePoint page: 

 

3.8) Navigate to ❶ Site Actions > More Options 

 

 

 

 

 

 

 

 

 

 

 

 

 

❶ 
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3.9) Select ❷ Page from the side menu, then ❸Web Part Page, then click ❹Create:  

3.10) In the screen that appears, ❺Enter a title for this page. 

3.11) Next, select a ❻site template, the ❼Layout Map, in the left-hand corner of the screen, will show 

you where the web parts will be listed in whichever template you select.  

3.12) Finally, select ❽Site Assets from the drop down menu, this will store this page in the Site Assets 

library you just created: 

 

 

 

 

 

 

 

 

 

 

 

 

3.13) After completing all of the fields, click on ❾Create. The page is now ready to edit. 

❷ 

❸ 

❹ 

❺ 

❻ 

❼ 

❽ 

❾ 
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Web Parts       

Web Parts are used to dynamically show the content of lists & libraries and to display rich text & 

graphics on SharePoint sites and pages. Below are common web parts used by CA SharePoint Sites: 

1) Documents Portal: Displays the content of a library or list from within the site. The data or doc-

uments can be filtered using views if necessary. 

2) Content Editor: A rich text editable space that can be used to display print information such as 

announcements, contact information, helpful links etc. 

3) Calendars: Displays a list in calendar view to highlight important dates, such as holidays. 

4) Graphics: Images or logos can be added throughout the site using web parts.  

 

 There are two areas where web parts can be created A) Site Homepages & B) Pages 

To enable editing of web parts on a SharePoint site’s home page or page follow these steps: 

3.14) With the homepage or site open, navigate to ❶Page > Edit Page: 

 

 

 

 

 

 

 

3.15) The page is now editable; the page template determines where ¸web-parts can be added: 

❶ 

· · · 

Web Parts on a Homepage Web Parts on a Page 
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3.16) Based on where you want a web part placed, click on the ❷Add a Web Part 

3.17) The following selection pane becomes visible at the top of the page: 

 

 

 

 

 

 

 

3.18) Web Parts are organized by category; these are the three most common web-parts: 

 

 

 

 

 

 

 

 

 

3.19) Next we will walk through the creation of three web-parts: A) List / B) Library / C) Text 

❷ 

Category Web Part Description 

Lists and Libraries A selection of all lists and 

libraries present on the 

site 

A box that displays data from lists (including cal-

endars) and libraries. Data can be filtered by view 

within the web-part. 

Media and Content Content Editor An editable box that allows you to input rich text 

(i.e. bold, italic, different fonts, hyperlinks, etc). 

Media and Content Image Viewer A box that can show any image stored in the Site 

Assets library. 

Continues on the next page 
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If you want to custom-

ize how the calendar 

displays on the page, 

click on the ❻arrow in 

the upper right-hand 

corner of the web part 

and select ❼Edit Web 

Part. 

 

The most common list displayed on web-parts are calendars. Below is a walkthrough to place a calendar 

web-part on the homepage of your site. 

3.20) From the opened Web-Part selection window, go to the ❸List and Libraries category and select a 

Calendar List, in this example this list is called ❹Team Meetings, then click ❺Add: 

 

 

 

 

3.21) The calendar list is now listed in the left web part column: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3.19) After selecting a web-part, click on ❸Add to add it to the site. 

3.20) Next we will walk through the creation of four web-parts: A) List / B) Library / C) Text / D) Image 

A) List 

❸ 

❹ 

❺ 

❻ 

❼ 
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3.22) The web part edit pane appears on the right hand side of the screen, below are the important op-

tions to take note of: 

 

 

 

 

 

3.23) Click on ❶Add a Wed Part in the right-hand column, then go to the ❷List and Libraries category 

and select a library, in this example the library is called ❸Reports, then click ❹Add: 

 

 

 

 

 

 

 

 

 

 

List Views 

❽  Selected View:  Select a view for the list 

from the drop-down menu. The default view is 

selected automatically, in the case of a calen-

dar list it is calendar. 

 

Appearance (click + to expand this menu) 

❾  Title:  Change how the web-part is labeled (note this does not 

change the title of the list). 

 

❿  Chrome Type:  Select whether you want 

the title and border to display or not.  

 

Selecting other options is not required for most web-parts. 

 

After making all necessary changes, click ⓫Apply, then ⓬OK.  

 

— A calendar web-part is now part of your page — 

❽ 

❾ 

❿ 

⓬ ⓫ 

B) Library 

❷ 
❸ 

❹ 

❶ 
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3.24) The library web-part appears in the right-hand column: 

 

 

 

 

 

 

 

 

 

 

If you want to customize how the library displays on the page, click on the ❺arrow in the upper right-

hand corner of the web part and select ❻Edit Web Part. 

3.25) The web part edit pane is the same as it was for a list. Refer to page 35 for help modifying the 

view and title. It is common to assign particular views to web-parts and rename the web-part to match 

that filter. Below is an example: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

— A library web-part is now part of your page — 

Default settings Filtered to Office 3 / Project 2 & Renamed 

❺ 

❻ 

NOTE: Any changes made to a view for a list or 

library will not automatically transfer to web-part 

views. Every time you make a change to a web-

part view. SharePoint will remind you of this with 

the following message: 

If changes are made to a particular view, return to the web-part edit pane and select the view 

again. After clicking Apply and OK the updated view will be visible through the web part. 
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3.26) Click on ❶Add a Wed Part in the left-hand column, then scroll down the category list to the 

❷Media and Content category and select ❸Content Editor, then click ❹Add: 

 

 

 

C) Text 

❷ 

❶ 

❸ 

❹ 

3.27) The content editor placeholder 

appears in the column you selected. 

Click on ❺Click here to add new 

content to add content to the web-

part: 
❺ 

3.28) In the blank space provided, 

type information that you want 

visible from the page. This may 

include, helpful links, contact in-

formation, etc. 

To insert hyperlinks, type an ad-

dress, SharePoint should automat-

ically create the link.  

If not, navigate to ❻Editing Tools 

> Insert > Link > From Address 

and type in the address. 

❻ 
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3.29) The Content Editor edit pane appears on the right side of the 

screen. There are two important options to take note of. Both options are 

found under the + Appearance section: 

❾Title: The title “content editor” is automatically assigned to a new 

content editor web-part. Change the title in this field if necessary. 

For this example, we will not show the title, so a change is not nec-

essary. 

❿Chrome Type: This options allows you to control whether a bor-

der and/or title appear around the web-part. For this example we 

will select “None”. 

3.30) After making necessary changes, click Apply, then OK. 

NOTE: Any changes to the appearance of borders / titles will not be visi-

ble until you select Stop Editing in the upper left-hand corner. 

 

— A Content Editor web-part is now part of your page — 

3.28) To edit a content editor, click on the Arrow in 

the upper right-hand corner of the web-part and se-

lect Edit Web Part: 

❼ 

❽ 

❾ 

❿ 

1) Menu Options: Navigate to the editing pane of a web-part, then click 

on the Layout menu option. Within the layout sub-menu there is an op-

tion to change the “zone”. This refers to the column that a web-part is 

located in. The number and location of these columns is determined by 

the template selected for the page. Homepages automatically have two 

columns (or zones): right and left. 

Continues on the next page 

3.31) Once a web-part is placed on a homepage or page, it can be moved around the page. There are 

two methods for doing this: 

Moving Web Parts  
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2) Drag & Drop: While in “edit mode”, web-parts can be dragged to new locations by clicking and hold-

ing the title bar of the web-part. Drag the web-part until a solid blue line is visible (this is where the 

web-part will land if the mouse is released). The web-part is now moved: 

3.32) After completing all web-part edits, close the ed-

iting view by navigating to Page > Stop Editing: 

 

We’ve completed a SharePoint Site, below is the home 

page with web-parts, lists, libraries, and pages: 
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SharePoint  Navigation 

As we saw in Module 1, there are two primary areas for site links throughout a SharePoint site: The link 

bar and side bar. Site designers have the ability to modify what is displayed on these lists. This 

walkthrough will explain how to do this. 

4.0) From the landing page for the site, navigate to ❶Site Actions > Site Settings. 

4.1) In the window that appears, navigate to ❷Look and Feel > Navigation. 

❶ 

❷ 

4.2) In the window that appears there are several options available. We will focus on the ❸Navigation 

Editing and Sorting section at the bottom of the page.  

❸ 

DO NOT modify 

permissions 
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4.3) The editing panel of the Navigation Editing and Sorting section, allows you to define which links are 

shown and hidden on the top and site navigation bars: 

Global Navigation = Top Navigation Bar (these links are visible in all sub-sites under this site) 

Current Navigation = Side Bar (these links are visible only in the current site) 

Folders under Current Navigation 

correspond to the headers on the 

side bar. 

Folders under Global Navigation cor-

respond to drop-down menus on the 

top bar. 

4.4) To add a new folder, select either Global 

Navigation or Current Navigation, then click on 

❹Add Heading. In the window that opens, enter 

a ❺Title and click ❻OK: 

4.5) This creates a new folder under Global Navi-

gation:  

❹ 

❺ 

❻ 

4.6) Click on the External Links folder, and click 

❼Add Link. 

Enter a name for the link in the ❽Title field, then 

enter the URL in the ❾URL field. Always check 

the ❿Open Link in New Window option. 

Finally, click ⓫OK to build the link. 

 

❼ 

❽ 

❾ 

❿ 

⓫ 
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4.7) A link to TSG now appears under the External Links folder, this translates to a link in a drop-down 

menu on the top navigation bar: 

 

 

 

 

 

4.8) Next, we will add a link to a page within the SharePoint site. Links to SharePoint pages are not au-

tomatically created, site designers must create these links. 

4.9) Begin by creating a “Pages” header. Click on the ❶Current 

Navigation header, then click  ❷Add Heading. 

4.10) In the pop-up window, name the field “Pages”, then click OK. 

4.11) Click on the new ❸Pages folder, then click ❹Add Link. 

4.12) In the pop-up that appears, complete all of the fields as you 

did for the TSG link for step (4.6), except for the “URL” field.       

Instead do the following: 

1. Click ❺Browse 

2. Navigate to your site, then click on ❻Site Assets. 

3. Select the Page to be linked, in this example, ❼FAM Citations. 

 

 

 

4.13) Click on ❽OK once you have selected the site element that will be linked. 

❷ 

❶ 

❸ 

❹ 

❺ 

❻ 

❼ 

❽ 
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4.14) The link to “FAM Citations” is now available on the side bar: 

 

 

 

 

 

 

 

4.15) Finally, there may be instances where you want to hide sites from the side bar. For example, you 

may not want to have “Site Assets” available to all users.  

4.16) To delete a link, select the ❶Link, then click ❷Delete. 

4.17) The link is removed; if you return to the main page, the 

link to Site Assets is no longer visible: 

 

 

 

 

 

— Site Navigation Section is complete — 

❶ 

❷ 
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SharePoint  Site Settings 

❶ 

❷ 

In order to modify the URL, name, or banner image of a site, follow these steps: 

5.0) From the landing page for the site, navigate to ❶Site Actions > Site Settings. 

5.1) In the window that appears, navigate to ❷Look and Feel > Title, description, and icon. 

 

 

 

 

 

 

 

 

 

 

5.2) In the window that appears there are several options available: 

NOTE: Place your logo image in the Site Assets folder and link to it directly. 


